Homebridge Config-UI-X ERR_CONNECTION_REFUSED



  • Moin Leute,

    ich hoffe euch gehts gut. Ich habe Mal wieder ein kleines Problem und stehe voll aufm Schlauch. Wahrscheinlich lässt sich das Problem ganz leicht lösen, aber ich bin wieder zu blind. Also hier erstmal mein Problem:

    Ich versuche für meine Homebridge die Config zu installieren. Meine Homebridge läuft ohne Probleme. Die Installation des Plugins hat auch ohne einen Fehler geklappt.
    Mein Eintrag in die config.json, die sich bei mir unter /var/hombridge/config.json befindet sieht wie folgt aus:

    {
            "bridge": {
                    "name": "Homebridge",
                    "username": "CC:22:3D:E3:CE:30",
                    "manufacturer": "homebridge.io",
                    "model": "homebridge",
                    "port": 51826,
                    "pin": "031-45-154"
            },
            "description": "Home Smart Home",
            "platforms": [
                    {
                            "platform": "config",
                            "name": "Config",
                            "port": 8581,
                            "sudo": true
                    }
            ],
            "accessories": []
    }
    

    Wenn ich jetzt die Homebridge starte, bekomme ich folgende Ausgaben:

    Jun 27 19:54:00 Homebridge systemd[1]: Started Node.js HomeKit Server.
    Jun 27 19:54:02 Homebridge homebridge[23278]: [2020-6-27 19:54:02] config.json (/home/homebridge/.homebridge/config.json) not found.
    Jun 27 19:54:03 Homebridge homebridge[23278]: [2020-6-27 19:54:03] Loaded plugin: homebridge-config-ui-x@4.23.1
    Jun 27 19:54:03 Homebridge homebridge[23278]: [2020-6-27 19:54:03] Registering platform 'homebridge-config-ui-x.config'
    Jun 27 19:54:03 Homebridge homebridge[23278]: [2020-6-27 19:54:03] ---
    Jun 27 19:54:03 Homebridge homebridge[23278]: Setup Payload:
    Jun 27 19:54:03 Homebridge homebridge[23278]: X-HM://0023ISYWYBICA
    Jun 27 19:54:03 Homebridge homebridge[23278]: Scan this code with your HomeKit app on your iOS device to pair with Homebridge:
    *Hier ist ein großer QR-Code*
    Jun 27 19:54:03 Homebridge homebridge[23278]: Or enter this code with your HomeKit app on your iOS device to pair with Homebridge:
    Jun 27 19:54:03 Homebridge homebridge[23278]:
    Jun 27 19:54:03 Homebridge homebridge[23278]:     ┌────────────┐
    Jun 27 19:54:03 Homebridge homebridge[23278]:     │ 031-45-154 │
    Jun 27 19:54:03 Homebridge homebridge[23278]:     └────────────┘
    Jun 27 19:54:03 Homebridge homebridge[23278]:
    Jun 27 19:54:03 Homebridge homebridge[23278]: [2020-6-27 19:54:03] Homebridge is running on port 35283.
    
    

    Das sieht ja an sich super aus, aber wenn ich dann versuche meine Config aufzurufen unter http://ip-adresse:8581 bekomme ich die Meldung ERR_CONNECTION_REFUSED.

    Ich habe schon versucht das Plugin neu zu installieren, ohne Erfolg.
    Ich habe versucht per iptables die Firewall zu deaktivieren, ohne Erfolg.
    Ich habe versucht alle optionalen Einstellungen für die Config anzugeben, aber auch hier blieb das Webinterface unerreichbar.

    Ich habe versucht die Homebridge bei Apple Home zu registrieren. Das hat geklappt ohne Probleme und nach einem Neustart, war die Config immer noch nicht erreichbar.

    Vielleicht hat ja jemand von euch noch eine Idee oder sieht direkt meinen Fehler…



  • Probiers mal über die Konsole mit

    nano /home/homebridge/.homebridge/config.json
    

    Und füg da mal deinen Block der Homebridge-Config-UI-X ein

    "platforms":[
       {
          "platform":"config",
          "name":"Config",
          "port":8581,
          "sudo":true
       }
    ],
    

    Ich vermute, dass das dein Problem evtl. beheben könnte, weil beim Startvorgang folgender Fehler erscheint:

    config.json (/home/homebridge/.homebridge/config.json) not found.

    Probier das mal und geb bescheid. Nur bin ich mir auch nicht sicher, ob das Plugin in dem Fall bereits über die config.json ausgelesen wird:

    Jun 27 19:54:03 Homebridge homebridge[23278]: [2020-6-27 19:54:03] Loaded plugin: homebridge-config-ui-x@4.23.1
    Jun 27 19:54:03 Homebridge homebridge[23278]: [2020-6-27 19:54:03] Registering platform 'homebridge-config-ui-x.config'
    

    Ansonsten vielleicht auch mal den Port des Serves ändern

    "port": 8581
    

    Wobei der Fehler ERR_CONNECTION_REFUSED schon eher darauf hindeutet, dass irgendwo irgendwas geblockt wird. Ich hab aktuell leider auch nicht mehr Anhaltspunkte, aber vielleicht fällt mir noch was ein. 🤔



  • Ok krass, also das Problem lag wirklich daran, dass die Config an dem angegebenen Ort gefehlt hat, was ich aber nicht ganz verstehe.

    Naja komisch. Trotzdem danke für die Hilfe!