Homebridge Hue richtig einrichten?



  • Hi,
    Ich hab mir das Makesmart-server image auf meinen Pi gepackt. Ziel damit, meine Innr Lampen in der Hue Bridge auch Homebridge kompatibel zu machen.

    Nur will nichts meine Hue Bridge oder keine Ahnung was genau erkennen.

    Bilder:
    Bild_2020-09-21_231612.png

    Bild_2020-09-21_231631.png



  • Hi @Fluqzy

    also ich hab bei mir das Hue-Plugin auch am laufen. Ich weiß nicht wie viel du gemacht hast oder was überhaupt genau, aber es reicht nicht nur die IP-Adresse einzugeben.

    Schick am besten mal den Log Code von Homebridge beim Starten, da steht auch nochmal was zu tun ist, wenn das Plugin falsch konfiguriert / eingerichtet ist.

    Wahrschenlich hast du noch keinen Nutzer bzw. keine Value Pair mit deiner Bridge.


    Aber keine Sorge…

    Schick jetzt einfach mal den Log von Homebridge, was während dem Starten angezeigt wird. 🙂



  • @cooper Jo,
    Hier das was beim starten alles im Log ist, bisher im Plugin nur ip drin

    Bild_2020-09-22_192642.png

    Bild_2020-09-22_192703.png



  • Wo ist der Rest? Also das von Hue? Wird da nichts mehr weiter angezeigt? Sollte nämlich eigentlich:

    Run Homebridge Hue for the first time, press the link button on (each of) your bridge(s), or unlock the deCONZ gateway(s) through their web app. Note the bridgeid/username (API key) pair for each bridge and/or gateway in the log output. Edit config.json to include these, see Configuration.

    Note that you cannot add these through the Homebridge Hue Settings in Homebridge Config UI X, but you can use the Homebridge Config Editor.

    Zitat: https://github.com/ebaauw/homebridge-hue#installation

    Solltest da eigentlich unterwiesen werden was du machen musst:

    1. Run Homebridge Hue for the first time, press the link button on (each of) your bridge(s)
    2. Note the bridgeid/username (API key) pair for each bridge and/or gateway in the log output.

    Der Output mit den Daten sollte wie gesagt dann im Homebridge Terminal angezeigt werden.

    Was sagt deine config.json?

    {
                "name": "Hue",
                "anyOn": true,
                "hosts": [
                    "192.168.178.39"
                ],
                "lights": true,
                "nativeHomeKitLights": false,
                "nativeHomeKitSensors": true,
                "nupnp": true,
                "resource": true,
                "users": {
                    "***": "***"
                },
                "platform": "Hue"
            }
    


  • Wirklich nichts kam, das ist das einzige was in der json drin ist.

    Kann aber auch nicht die Module in der Homebridge hue Einstellung ändern

    {
        "bridge": {
            "name": "makesmart-server",
            "username": "0E:30:57:BA:56:63",
            "port": 51358,
            "pin": "123-45-678"
        },
        "accessories": [],
        "platforms": [
            {
                "name": "Config",
                "port": 8581,
                "platform": "config"
            },
            {
                "name": "Hue",
                "anyOn": true,
                "hosts": [
                    "192.168.178.30"
                ],
                "nativeHomeKitLights": true,
                "nativeHomeKitSensors": true,
                "nupnp": true,
                "resource": true,
                "platform": "Hue"
            }
        ]
    }
    


  • Jetzt tut sich was ^^

    5befbdef-2aa3-4717-8405-e1a4a592ec38-image.png

    0bc39640-545a-4224-ae8a-b54e96df90b8-image.png



  • Ok, hab jetzt alles drinne passt soweit ganz gut



  • Freut mich, dass es jetzt geklappt hat 👍

    PS: Was war jetzt eigentlich genau der Fehler? 🙈



  • Was war jetzt eigentlich genau der Fehler? 🙈

    ähhm es stand nie in der Console dass ich den Button in der Bridge drücken soll und den User einfügen soll, kp warum